杭电3342(拓扑排序+判断是否为有向无环图)

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?
We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.
Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0. TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship. If it is legal, output “YES”, otherwise “NO”.

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

思路:

题意:QQ群中有很多师徒关系,一个师傅可能有很多徒弟,一个徒弟可能有很多师傅。A是B的师傅,B是C的师傅,可以推出A是C的师傅。但A是B的师傅,B也是A的师傅是不合法的。给出师徒关系,判断是否存在不合法现象。

方法:拓扑排序,判断是否为有向无环图。如果任何一个节点的入度都不为0,则有环。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
#define maxn 110
int n,m,flag;//n个人m对关系 
int team[maxn][maxn];
int in[maxn];//入度 
int topo[maxn];

int toposort()
{
    for(int i=0;i<n;i++)
    {
        int tmp=n;
        for(int j=0;j<n;j++)
        {
            if(in[j]==0)//找到入度为0的顶点 
            {
                tmp=j;//暂存节点的编号 
                in[j]--;//将该点删除,即入度减1 
                break;
            }
        }
        //若tmp=n,说明任何一个节点入度都不为0,则有环 
        if(tmp==n) return 0;
        //将tmp点(即入度为0的点)所连的节点都删掉,即入度减1 
        for(int k=0;k<n;k++)
        {
            if(team[tmp][k]) in[k]--;
        }
    }
    return 1;
}

int main()
{
    int x,y;//一组中的两支队伍 
    while(cin>>n>>m)
    {
        if(n==0&&m==0) break; 
        memset(team,0,sizeof(team));
        memset(in,0,sizeof(in));
        for(int i=0;i<m;i++)
        {
            cin>>x>>y;//输入师徒
            if(team[x][y]==0)
            {
                team[x][y]=1;//师徒连通
                in[y]++;//徒弟入度加1
            }
        }
        flag=toposort();
        if(flag) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值