杭电Robberies解题报告

5 篇文章 0 订阅
2 篇文章 0 订阅

题目:

Robberies

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6
题目大意:

   题目意思为一个人要去银行抢钱,但是又怕被抓到,所以事先调查了各个银行的钱数和被抓的概率。要求在不被抓到的前提下能偷到的最多的钱。输入第一行为T,表示T组测试数据,接下来一行为被抓的概率和银行的个数,接下来依次为这n家银行的钱数和被抓的概率。

解题思路:

   本题如果利用简单的背包问题来解决,有一定的困难,首先在于概率为小于1的数,你可以乘以一个数让他变成整数,但是这样做不现实,程序肯定会超时,因为数据可能达到小数点后的九位数,所以只能转换一下思路,既然有被转的概率p,那么不被抓的概率也就是1-p,不被抓的概率等于各个不被抓的概率的乘积,所以可以刘永不被抓的概率来解决这道题,一下为解题的程序代码。

程序代码:

   #include<iostream>
#include<cstring>
using namespace std;


int M[105];
double P[105];
double f[10005];


int main()
{
int T;
cin>>T;
while(T--)
{
memset(M,0,sizeof(M));                                   各个数组置零操作
memset(P,0,sizeof(P));
memset(f,0,sizeof(f));
int n,sum=0;
int i,j;
double p,rate;
cin>>p;
cin>>n;
p=1-p;                                                                     计算不被抓的概率
for(i=1;i<=n;i++)
{
cin>>M[i];
cin>>rate;
P[i]=1-rate;                                                   输入各个银行不被抓的概率
sum+=M[i];                                                  计算银行钱数总和。
}
f[0]=1;
for(i=1;i<=n;i++)                                                背包01,完全可以看伪代码写出来
for(j=sum;j>=M[i];j--)
{
if(f[j-M[i]]*P[i]>f[j])                              不被抓的概率等于各个不被抓的概率的乘积
f[j]=f[j-M[i]]*P[i];
}
for(i=sum;i>=0;i--)                                               输出最大的可以得到的钱数
if(f[i]>p)
{
cout<<i<<endl;
break;
}
}
return 0;
}

解题感想;

       本题的解题思路与其他01背包题目有所不同在于从所给问题的反面来解决这个问题,这也是一个很重要的思想,从事物的反面来做,有时候会得到意想不到的结果,而且可以简化题目,通过这道题,也让我领悟到在以后的解题过程中可以从题目的相反反面来考虑,总之,这道题目不仅仅可以更加熟悉背包问题的解决更加可以锻炼我们的思维能力。是一道很不错的题目。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值