HDU 4576(概率DP+滚动数组)


  
  

刚开始用搜索写着玩了玩,超时是必然,后来看题解可以才知道搜索到的当前深度所有点的可能性(即概率)是本层搜索中所有到达本点概率的和。所以用两个数组分别存上一次的概率和更新后的概率就好了。原来概率DP就是求概率,然后用动态规划推导,滚动数组就是不断的刷新一个数组,一个交换位置用,算是见识了。加油加油!

Description

Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise. 
At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.  Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands. 

Input

There are multiple test cases.  Each test case contains several lines.  The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).  Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.    The input end with n=0,m=0,l=0,r=0. You should not process this test case. 

Output

For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.

Sample Input

3 1 1 2
1
5 2 4 4
1
2
0 0 0 0

Sample Output

0.5000
0.2500




#include <bits/stdc++.h>
using namespace std;
typedef pair<int, int> P;
typedef long long LL;
#define INF 0x3f3f3f3f
#define PI acos(-1)
#define MAX_N 10000
//#define LOCAL
int n, m, l, r;

double dp[2][205];
int main()
{
	#ifdef LOCAL
		freopen("b:\\data.in.txt", "r", stdin);
	#endif
    while(scanf("%d%d%d%d", &n, &m, &l, &r))
    {
        if(!n && !m && !l && !r)
            break;
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 1;
        int t = 0, k;//滚动数组
        for(int i = 0; i < m; i++)
        {
            int mov;
            scanf("%d", &mov);
            k = t^1;
            for(int c = 0; c < n; c++)
                dp[k][c] = 0;
            for(int j = 0; j < n; j++)
            {
                if(!dp[t][j])
                    continue;
                dp[k][(j+mov)%n] += dp[t][j]*0.5;
                dp[k][(j-mov+n)%n] += dp[t][j]*0.5;
            }
            t = k;
        }
//        for(int i = 0; i < n; i++)
//            cout << dp[t][i] << " " ;
//        cout << endl;
        double ans = 0;
        for(int i = l; i <= r; i++)
            ans += dp[t][i-1];
        printf("%.4lf\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值