UVA10391 Compound Words(STL)

题面:

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
 

Input:

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.
 

Output:

Your output should contain all the compound words, one per line, in alphabetical order.
 

Sample Input:

a

alien

born

less

lien

never

nevertheless

new

newborn

the

zebra

 

Sample Output:

alien

newborn

 

分析:

题意就是要你找出给出的单词里,由两个单词组合而成的复合词,比如alien,就是由输入里的a和lien两个单词组成的。

用一个set把所有单词记录下来,因为数据比较小只有120000,所以把每个单词拆开找一遍就是了,这里使用了string中的substr函数来拆分单词,用set中的find()函数来寻找拆分后的部分是否在set中存在,如果在set中没有找到对应内容,会返回set.end()的地址。

 

AC代码:

#include<bits/stdc++.h>
using namespace std;
set<string>s;
string temp, a, b;

int main(){
	while(cin>>temp) s.insert(temp);
	
	for(set<string>::iterator iter = s.begin(); iter != s.end(); iter++){
		temp = *iter;
		for(int i = 0; i < temp.length(); i++){
			a = temp.substr(0, i+1);
			b = temp.substr(i+1, temp.length()-1);
			if(s.find(a) != s.end() && s.find(b) != s.end()){
				cout<<temp<<endl;
				break;
			}
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值