UVA 10391 Compound Words

UVA 10391 Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn

 

题意:找出由两个单词构成的单词

 

#include <iostream>

#include <algorithm>

#include <cstring>

#include <map>

using namespace std;

const int MAX=120000+5;

map<string,int>Map;

char str[MAX][100];

int main()

{

    int n=0;

    Map.clear();

    while(cin>>str[n])

    {

        Map[str[n]]=1;

        n++;

    }

    int i,j,l;

    for(i=0;i<n;i++)

    {

        l=strlen(str[i]);

        for(j=0;j<l;j++)

        {

            char a1[100];

            char a2[100];

            memset(a1,'\0',sizeof(a1));  //注意初始化,不初始化WA

            memset(a2,'\0',sizeof(a2));

            strncpy(a1,str[i],j);

            strncpy(a2,str[i]+j,l-j);

            if(Map[a1]&&Map[a2])

            {

                cout<<str[i]<<endl;

                break;

            }

        }

    }

    return 0;

}

 

结果按 ctrl+z出来

 

#include<cstdio>

#include<iostream>

#include<map>

#include<string>

#include<cstring>

using namespace std;

string s[130000];

map<string,int>m;

int main()

{

    int l=0,j,k,i;

    while(cin>>s[l])

    {

        m[s[l]]=1;

        l++;

    }

    string a,b;

    for(j=0; j<l; j++)

    {

        k=s[j].size();

        for(i=1; i<k-1; i++)

        {

            a=s[j].substr(0,i);

            if(m.find(a)!=m.end())

            {

                b=s[j].substr(i,k-1);

                if(m.find(b)!=m.end())

                {

                    cout<<s[j]<<endl;

                    break;

                }

            }

            else

                continue;

        }

    }

    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值