数据结构实验之二叉树四:还原二叉树

Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input
输入数据有多组,每组数据第一行输入 1 个正整数 N(1 <= N <= 50) 为树中结点总数,随后 2 行先后给出先序和中序遍历序列,均是长度为 N 的不包含重复英文字母 ( 区分大小写 ) 的字符串。

Output
  输出一个整数,即该二叉树的高度。
Example Input
9 
ABDFGHIEC
FDHGIBEAC
Example Output
5
//还原二叉树详解;
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cmath>

using namespace std ;


//结构体;
struct stu
{
    char data ;
    struct stu *lchild ;
    struct stu *rchild ;
};


//还原二叉树;
void creat(struct stu *&p , int n , char a[] , char b[])
{
    if(n==0)
        p = NULL ;
    else
    {
        p = (struct stu *)malloc(sizeof(struct stu)) ;
        p -> data = a[0] ;
        int i ;
        for(i=0;b[i]!='\0';i++)  //不能在for中定义int i,这样下面的程序没办法用i了,因为在for中定义的i,只能在for中使用,要想在别的地方或者在下面用,那么就要在for外面定义,就如int i; for();
            if(b[i]==a[0])
            break;
        creat(p->lchild,i,a+1,b) ;
        creat(p->rchild,n-i-1,a+i+1,b+i+1) ;
    }
}


//二叉树的高度;
int get_gaodu(struct stu *&p)
{
    if(p!=NULL)
    {
        int a = get_gaodu(p->lchild) ;
        int b = get_gaodu(p->rchild) ;
        if(a>b)
        return a+1;
    else
        return b+1;
    }
    else
        return 0 ;
}

//主函数 ;
int main()
{
    int n ;
    char a[100010] , b[100010] ;
    while(~scanf("%d",&n))
    {
        int sum = 0 ;
        cin >> a >> b ;
        struct stu * p ;
        creat(p,n,a,b);
        sum = get_gaodu(p) ;
        cout << sum << endl ;
    }
    return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值