数据结构基础 复原二叉树

原题

复原二叉树

Time Limit: 1 Sec Memory Limit: 32 MB


Description

小明在做数据结构的作业,其中一题是给你一棵二叉树的前序遍历和中序遍历结果,要求你写出这棵二叉树的后序遍历结果。

Input

输入包含多组测试数据。每组输入包含两个字符串,分别表示二叉树的前序遍历和中序遍历结果。每个字符串由不重复的大写字母组成。

Output

对于每组输入,输出对应的二叉树的后续遍历结果。

Sample Input


DBACEGF ABCDEFG
BCAD CBAD

Sample Output


ACBFGED
CDAB

代码

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
using namespace std;
string A,B;
int n;
struct node
{
    char val;
    node *ch[2];
};

//在B中寻找非叶子结点位置
int Search(char x,string b,int n)
{
    for(int i=0;i<n;i++)
    {
        if(x==b[i])
        {
            return i;
        }
    }
    return 0;
}
//复原二叉树
node *Restore(string A,string B,int n)
{
    if(n<=0)
    {
        return NULL;
    }
    node *p=new node();
    p->val=A[0];
    p->ch[0]=p->ch[1]=NULL;
    int i=Search(A[0],B,n);
    //左子树递归,右子树递归
    p->ch[0]=Restore(A.substr(1),B,i);
    p->ch[1]=Restore(A.substr(1+i),B.substr(i+1),n-1-i);
    return p;
}
//后序遍历
void Postorder(node *t)
{
    if(t==NULL)
    {
        return;
    }
    Postorder(t->ch[0]);
    Postorder(t->ch[1]);
    printf("%c",t->val);
}

int main()
{
    //freopen("in.txt","r",stdin);
    while(cin>>A>>B)
    {
        n=A.size();
        node *root=Restore(A,B,n);
        Postorder(root);
        cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值