ZOJ3911 Prime Query(线段树区间修改+单点更新)

Prime Query


Time Limit: 5 Seconds      Memory Limit: 196608 KB


You are given a simple task. Given a sequence A[i] with N numbers. You have to perform Q operations on the given sequence.

Here are the operations:

 

  • A v l, add the value v to element with index l.(1<=V<=1000)
  • R a l r, replace all the elements of sequence with index i(l<=i<= r) with a(1<=a<=10^6) .
  • Q l r, print the number of elements with index i(l<=i<=r) and A[i] is a prime number

 

Note that no number in sequence ever will exceed 10^7.

Input

The first line is a signer integer T which is the number of test cases.

For each test case, The first line contains two numbers N and Q (1 <= N, Q <= 100000) - the number of elements in sequence and the number of queries.

The second line contains N numbers - the elements of the sequence.

In next Q lines, each line contains an operation to be performed on the sequence.

Output

For each test case and each query,print the answer in one line.

Sample Input

1
5 10
1 2 3 4 5
A 3 1      
Q 1 3
R 5 2 4
A 1 1
Q 1 1
Q 1 2
Q 1 4
A 3 5
Q 5 5
Q 1 5

Sample Output

2
1
2
4
0
4

Author: HUA, Yiwei
Source: ZOJ Monthly, October 2015
 

 

一、原题地址

点我传送

 

二、大致题意

有三种操作;

1、给某个单点加上v

2、将区间[ l, r ]替换成v

3、查询区间[l, r ]内有多少个素数。

 

三、思路

都是一些线段树的基本操作,关键在于判断素数需要先打出素数表。

 

四、代码

#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
#include<cmath>
#include<iostream>
#include<deque>
#include<map>
#include<stack>
#include<set>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;


const int MAXN = 1e7+5;
int Mark[MAXN];
int prime[MAXN];
int Prime()
{
	int tot = 0;
	memset(Mark, 0, sizeof(Mark));
	Mark[0] = 1; Mark[1] = 1;
	for (int i = 2; i < MAXN; i++)
	{
		if (Mark[i] == 0) {
			prime[tot++] = i;
		}
		for (int j = 0; j < tot && prime[j] * i < MAXN; j++)
		{
			Mark[i * prime[j]] = 1;
			if (i % prime[j] == 0) {
				break;
			}
		}
	}
	return tot;
}


const int N = 100005;
LL a[N];
LL  lazy[N << 2];
int n, q;
struct Tree
{
	int l, r;
	LL sum;
	LL realNum;
	int mid()
	{
		return (l + r) >> 1;
	}
}tree[N<<2];

void PushUp(int rt)
{
	tree[rt].sum = tree[rt << 1].sum + tree[rt << 1 | 1].sum;
}

void PushDown(int rt,int m)
{
    if (lazy[rt])
    {
        lazy[rt << 1] = lazy[rt];
        lazy[rt << 1 | 1] = lazy[rt];
        if(!Mark[lazy[rt] ])
        {
            tree[rt << 1].sum =(m - (m >> 1));
            tree[rt << 1 | 1].sum = (m >> 1);
        }
        else
        {
            tree[rt << 1].sum =0;
            tree[rt << 1 | 1].sum =0;
        }
        tree[rt << 1].realNum=lazy[rt];
        tree[rt << 1 | 1].realNum=lazy[rt];
        lazy[rt] = 0;
    }
}

void build(int l, int r, int rt)
{
	tree[rt].l = l;
	tree[rt].r = r;
	lazy[rt] = 0;
	if (l == r)
	{
		tree[rt].realNum = a[l];
		if(!Mark[tree[rt].realNum])tree[rt].sum=1;
		else tree[rt].sum=0;

		//printf("Quer ::%d %d  %d\n",tree[rt].l,tree[rt].r,tree[rt].sum);
		return;
	}
	int m = tree[rt].mid();
	build(l, m, (rt << 1));
	build(m + 1, r, (rt << 1 | 1));
	PushUp(rt);
}

void Replace(LL c, int l, int r, int rt)
{
    if (tree[rt].l == l&&tree[rt].r==r)
    {
        lazy[rt] = c;
        if(!Mark[lazy[rt] ])
        {
            tree[rt].sum = (r-l+1);
        }
        else
        {
            tree[rt].sum =0;
        }
        return;
    }
	if (tree[rt].l == tree[rt].r)return;
	int m = tree[rt].mid();
	PushDown(rt, tree[rt].r - tree[rt].l + 1);
	if (r <= m)Replace(c, l, r, rt << 1);
	else if (l > m)Replace(c, l, r, rt << 1 | 1);
	else
	{
		Replace(c, l, m, rt << 1);
		Replace(c, m + 1, r, rt << 1 | 1);
	}
	PushUp(rt);
}

LL Query(int l, int r, int rt)
{
    //printf("Quer ::%d %d  %d\n",tree[rt].l,tree[rt].r,tree[rt].sum);
	if (l == tree[rt].l&&r == tree[rt].r)
	{
		return tree[rt].sum;
	}
	int m = tree[rt].mid();
	PushDown(rt, tree[rt].r - tree[rt].l + 1);
	LL res = 0;
	if (r <= m)res += Query(l, r, rt << 1);
	else if (l > m)res += Query(l, r, rt << 1 | 1);
	else
	{
		res += Query(l, m, rt << 1);
		res += Query(m + 1, r, rt << 1 | 1);
	}
	return res;
}

void Add(LL c, int k, int rt)
{
    if (tree[rt].l == k&&tree[rt].r==k)
	{
	    tree[rt].realNum += c;
		if(!Mark[tree[rt].realNum])tree[rt].sum=1;
		else tree[rt].sum=0;
		//printf("******%d  %lld\n",k,tree[rt].realNum);
		return;
	}
	int m = tree[rt].mid();
	PushDown(rt, tree[rt].r - tree[rt].l + 1);

	if (k <= m)Add(c, k, rt << 1);
	else if (k > m)Add(c, k, rt << 1 | 1);
	PushUp(rt);
}

int main()
{
    int T;
    int tot=Prime();
    Mark[1]=0;
    scanf("%d",&T);
    char op[3];
    while(T--)
    {
        scanf("%d %d",&n,&q);
        for(int i=1;i<=n;i++) scanf("%lld",&a[i]);
        build(1,n,1);
        while(q--)
        {
            scanf("%s",op);
            if(op[0]=='A')
            {
                LL v;
                int l;
                scanf("%lld %d",&v,&l);
                Add(v,l,1);
            }
            else if(op[0]=='Q')
            {
                int ql,qr;scanf("%d %d",&ql,&qr);
                printf("%lld\n",Query(ql,qr,1));
            }
            else
            {
                LL a;int ql,qr;
                scanf("%lld %d %d",&a,&ql,&qr);
                Replace(a,ql,qr,1);
            }
        }
    }
}

 

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
应用背景为变电站电力巡检,基于YOLO v4算法模型对常见电力巡检目标进行检测,并充分利用Ascend310提供的DVPP等硬件支持能力来完成流媒体的传输、处理等任务,并对系统性能做出一定的优化。.zip深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值