UFUG2601-OJ palindrome

PS:如果读过题了可以跳过题目描述直接到题解部分
链接:UFUG2601-OJ palindrome

题目

题目描述

Given an integer x x x, returntrueif x x x is a palindrome, andfalseotherwise.

输入格式

only one integer number x x x. (Ensure that x x x is within the range of an int.)

输出格式

Trueif x x x is a palindrome,Falseotherwise

样例 #1

样例输入 #1

121

样例输出 #1

True

样例 #2

样例输入 #2

-121

样例输出 #2

False

样例 #3

样例输入 #3

10

样例输出 #3

False

题解

这道题题目的意思是判断一个数(包括正负号)是否为回文数,直接用字符的格式输入,用函数strlen提取字符长度,首尾依次比较即可。

需要注意的是,输入字符串时,字符是从0开始存储的。

代码实现

//palindrome
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char x[105];
int l;

int main(){
	cin>>x;
	l=strlen(x);
	int i=0;
	while(i<=(l>>1)){
		if(x[i]!=x[l-1-i]){
			printf("False\n");
			return 0;
		}
		++i;
	}
	printf("True\n");
	return 0;
}
  • 9
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

月半流苏

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值