1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2



根据后续和中序遍历建立二叉树,然后再进行层次遍历!



#include<iostream>
#include<vector>
#include<queue>
using namespace std;

struct Node
{
	Node *lChild;
	Node *rChild;
	int val;
	Node(){ lChild = NULL; rChild = NULL; val = 0; }
};

vector<int>vecPost, vecInorder,vecLevel;
queue<Node*>q;

int findRootPos(int start,int end,int pend)
{
	int pos = 0;
	for (int i = start; i <= end; ++i)
	{
		if (vecInorder[i] == vecPost[pend])
		{
			pos = i;
			break;
		}
	}
	return pos;
}

void createTree(int pstart,int pend,int istart,int iend,Node *&root)
{
	if (istart > iend)
		return;
	int rootPos = findRootPos(istart,iend,pend);
	root = new Node();
	root->val = vecInorder[rootPos];
	createTree(pstart,pstart+rootPos-istart-1,istart,rootPos-1,root->lChild);
	createTree(pend-iend+rootPos,pend-1,rootPos+1,iend,root->rChild);
}

void levelOrder(Node *root)
{
	if (!root)
		return;
	Node *n;
	q.push(root);
	while (!q.empty())
	{
		n = q.front();
		q.pop();
		vecLevel.push_back(n->val);
		if (n->lChild)
		{
			q.push(n->lChild);
		}
		if (n->rChild)
		{
			q.push(n->rChild);
		}
	}
}

int main()
{
	int num, value;
	scanf("%d",&num);
	Node *root = NULL;
	for (int i = 0; i < num; ++i)
	{
		scanf("%d",&value);
		vecPost.push_back(value);
	}
	for (int i = 0; i < num; ++i)
	{
		scanf("%d",&value);
		vecInorder.push_back(value);
	}
	createTree(0,num-1,0,num-1,root);
	levelOrder(root);
	for (int i = 0; i < vecLevel.size()-1; ++i)
	{
		printf("%d ",vecLevel[i]);
	}
	if (!vecLevel.empty())
		printf("%d",vecLevel[vecLevel.size()-1]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值