1027. Colors in Mars (20)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456
 
 
#include<iostream>
using namespace std;

int main()
{
	int R, G, B;
	int res[6];
	char cres[7];
	scanf("%d%d%d",&R,&G,&B);
	res[0] = R / 13;
	res[1] = R % 13;
	res[2] = G / 13;
	res[3] = G % 13;
	res[4] = B / 13;
	res[5] = B % 13;
	
	for (int i = 0; i < 6; ++i)
	{
		if (res[i] >= 0 && res[i] <= 9)
			cres[i] = res[i] + '0';
		if (res[i] == 10)
			cres[i] = 'A';
		if (res[i] == 11)
			cres[i] = 'B';
		if (res[i] == 12)
			cres[i] = 'C';
	}
	cres[6] = '\0';
	printf("#%s",cres);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值