Palindrome

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

题意:题中给了一个长度为n的字符串,求至少再加上几个字符是它变成回文字符串。

思路:我们先求出字符串a的逆序字符串b,然后求这两个字符串的最长公共子序列,所求的公共子序列就是已经匹配好的字符,还剩下n-dp[n][n]没有匹配成功,然后在相应位置上加上对应字符即可,需要注意的是,这道题数组dp不能写成 int 型,会内存超限的,应写成unsigned short型,因为unsigned shrot占字节小,代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[5005],b[5005];
unsigned short dp[5005][5005]; //unsigned short 无符号短整型,数值范围为:0~65535;
                               //int 有符号基本类型,数值范围为::-32768~32767。
int main()
{
    int n,i,j;
    memset(dp,0,sizeof(dp));
    scanf("%d",&n);
    scanf("%s",a);
    for(j=0;j<n;j++)
        b[j]=a[n-j-1];  // b是a的逆序
    for(i=0;i<n;i++)    //求a,b最长公共子序列
    {
        for(j=0;j<n;j++)
        {
            if(a[i]==b[j])
                dp[i+1][j+1]=dp[i][j]+1;
            else
                dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
        }
    }
    printf("%d\n",n-dp[n][n]);  //n减最长公共子序列即可算出
    return 0;
}

 

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值