Tree Recovery

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 
 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

题意:给出前序便利和中序便利,求它的后序便利。

思路:由前序遍历先根,可知道D是树的根,再看在中序遍历中D左边是ABC,所以可知道ABC一定在D的左子树上,而EFG在D的右子树上,那么前序遍历为BAC,中序遍历为ABC,所以B为根,在中序遍历中A在B的左边,C在B的右边,所以A为B的左孩子,C为B的右孩子。EFG的情况于此类似,所以做这个题是用递归来做,分别找到左子树和右子树,然后输出即可,代码如下:

                  //那么由前序遍历先根,可知道D是树的根,
                  //再看在中序遍历中D左边是ABC,
                  //所以可知道ABC一定在D的左子树上,而EFG在D的右子树上。
                  //那么前序遍历为BAC,中序遍历为ABC,
                  //所以B为根,在中序遍历中A在B的左边,
                  //C在B的右边,所以A为B的左孩子,C为B的有孩子。
#include<stdio.h>
#include<string.h>
void angel(int len,char *s1,char *s2)
{
    int t;
    if(len<=0)
        return ;
    t=strchr(s2,s1[0])-s2; //strchr的作用是查找s1【0】第一次出现的位置
    angel(t,s1+1,s2); //这个是采用递归得到左子树
    angel(len-t-1,s1+t+1,s2+t+1);//这个是采用递归得到右子树
    printf("%c",s1[0]);
}
int main()
{
    char s1[35],s2[35];
    int l;
    while(~scanf("%s %s",s1,s2))
    {
        l=strlen(s1);
        angel(l,s1,s2);
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值