FatMouse and Cheese

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:给出n和k,代表n行n列,每次最多走k步,小老鼠从(0,0)点出发,每次只能往数值比当前位置大的地方走,每次走到一个位置加上那个位置的数值,问能得到的最大数值是多少?

思路:这个题可以用深搜去做,从(0,0)点出发,两层for循环记录位置,外层代表四个方向,内层是走了多少步,走到一个位置如果数值比前一步大的话,加上数值继续dfs,每次返回时更新一下最大值。在两层for循环结束后,得到的maxx的值就是该点能得到的最多奶酪数,然后将maxx赋给book[x][y]记录一下这个点的最大奶酪数,这个题有一个剪枝,如果遇到一个点它被记录过了,那么直接用就行了,不用再搜索。最后返回到主函数加上(0,0)点对应的值就好了,代码如下:

#include<stdio.h>
#include<string.h>
int n,k;
int a[110][110],book[110][110];
int next[4][2]= {0,1,1,0,0,-1,-1,0};
int angel(int x,int y)
{
    if(book[x][y])
        return book[x][y]; //剪枝,以后可能再遇到这个点
    int maxx=0;
    for(int i=0; i<4; i++)
    {
        for(int j=1; j<=k; j++)
        {
            int tx=x+next[i][0]*j;
            int ty=y+next[i][1]*j;
            if(tx<0||tx>=n||ty<0||ty>=n)
                continue;
            if(a[tx][ty]>a[x][y])
            {
                int tt=angel(tx,ty)+a[tx][ty];
                if(tt>maxx)
                    maxx=tt;
            }
        }
    }
    book[x][y]=maxx;
    return book[x][y];
}
int main()
{
    while(~scanf("%d %d",&n,&k)&&(n!=-1||k!=-1))
    {
        memset(book,0,sizeof(book));
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
                scanf("%d",&a[i][j]);
        }
        printf("%d\n",angel(0,0)+a[0][0]);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值