poj2002 Squares 解题报告

                                                                                                                                                   Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 9869 Accepted: 3518

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
x1+y26
1

 

 额,题目意思很简单,就是给你一堆点的集合,让你找出所有可由这些点构成的正方形个数。

开始就想到把所有得点都搜一遍,可以用两个点来确定正方形的一条边,然后可以用这两点的坐标得到另外的两点坐标信息。再在所有的点中搜索符合条件的点是否存在。

如果正方形的一条边确定了,而且这条边的两个端点为A(x1,y1),B(x2,y2),那么可以有简单的几何计算得

另外两点为C(x1+y2-y1,y1+x1-x2),D(x2+y2-y1,y2+x1-x2);CD为AB右上方的边。

在这里我们只需要查找AB边右上方的符合条件的点,因为搜索AB左下方的点也就相当于左下方的点搜索右上方。

这里用到了Stl中的二分查找函数binary_search(v,v+n,p,op)可以轻松解决找点的过程(开始自己写了几个查找的函数可是都TLE了  .....T_T)

代码:

 

#include<iostream>
#include<algorithm>
#include<climits>
using namespace std;
int n;
struct point{
  int x;
  int y;
   }v[1002];
bool cmp(const struct point &a,const struct point &b)
{
 if(a.x==b.x)
 return a.y<b.y;
 else
 return a.x<b.x; 
}
int main()
{
   while(scanf("%d",&n)&&n)
  { 
    for(int i=0;i<n;i++)
    {
      scanf("%d%d",&v[i].x,&v[i].y);  
         }
 if(n<4)
 {printf("0\n");}
 else{
  int ans=0;   
  sort(v,v+n,cmp);
  for(int i=0;i<n;i++)
  {
  for(int j=i+1;j<n;j++)
  {
    point c,d; 
      c.x = v[i].x + v[j].y - v[i].y; 
      c.y = v[i].y + v[i].x - v[j].x; 
      d.x = v[j].x + v[j].y - v[i].y; 
      d.y = v[j].y + v[i].x - v[j].x;            
    if(!binary_search(v,v+n,c,cmp))
    continue;
    if(!binary_search(v,v+n,d,cmp))
    continue;
    ans++; 
      }
   }
   printf("%d\n",ans/2);      
      }     
}
return 0;
   }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值