sdut oj1208 Catch That Cow(BFS)

题目链接:点击打开链接

Catch That Cow

Time Limit: 2000MS Memory limit: 65536K

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

提示

题意:输入两个数n,k,求从n到k最少的步数,可以前进1后退1或者当前位置*2

代码实现:

#include <bits/stdc++.h>
using namespace std;
#define maxsize 1000100

bool vis[maxsize];

struct node
{
    int data;///当前的位置
    int Count;///已经走过的步数
}t1,t2;

int n,k;
int Move[] = {-1,1};

void BFS()
{
    queue <node> Q;
    t1.data = n;
    t1.Count = 0;
    Q.push(t1);
    vis[n] = 1;
    while(!Q.empty())
    {
        t2 = Q.front();
        Q.pop();
        if(t2.data == k)
        {
            printf("%d",t2.Count);
            break;
        }
        for(int i = 0; i< 3;i++)///i=0后退一步,i=1前进一步,i=2,当前位置乘二
        {
            if(i == 2)
            {
                t1.data = t2.data * 2;
            }
            else
            {
                t1.data = t2.data + Move[i];
            }
            if(!vis[t1.data]&&t1.data >= 0&&t1.data <= 100000)
            {
                t1.Count = t2.Count + 1;
                Q.push(t1);
                vis[t1.data] = 1;
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(vis,0,sizeof(vis));
        BFS();
        printf("\n");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值