杭电多校赛第二场 Game

Problem Description

Alice and Bob are playing a game.
The game is played on a set of positive integers from 1 to n.
In one step, the player can choose a positive integer from the set, and erase all of its divisors from the set. If a divisor doesn't exist it will be ignored.
Alice and Bob choose in turn, the one who cannot choose (current set is empty) loses.
Alice goes first, she wanna know whether she can win. Please judge by outputing 'Yes' or 'No'.

 

 

Input

There might be multiple test cases, no more than 10. You need to read till the end of input.
For each test case, a line containing an integer n. (1≤n≤500)

 

 

Output

A line for each test case, 'Yes' or 'No'.

 

 

Sample Input

 

1

 

 

Sample Output

 

Yes

该题就是简单的博弈题,当素数数量为奇数或者0时,ALICE赢,否则BOB

#include<bits/stdc++.h>

using namespace std;

int a[510] , book[510];

int main()
{
    book[1] = 1;
    for(int i = 2; i <= 500  ; i++ )
    {
        if(book[i])
            continue;
        if(!book[i])
        {
            for(int j = i + i ; j <= 500 ; j += i)
                book[j] = 1;
        }
    }
    int num = 0;
    for(int i = 1; i <= 500 ; i ++)
    {
        if(!book[i])
        {
            num ++;
            a[i] = num;
        }
    }
    int n ;
    while(~scanf("%d" , &n))
    {
        if(a[n] == 0)
        {
            printf("Yes\n");
            continue;
        }
        if(a[n] % 2 == 1)
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值