A - ACM Computer Factory

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part j, Di,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ N ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.

第一次打网络流的题,看了模板后,自己又打了四五遍,终于打(默?)出来了

本来还想打一个邻接表的,但是这道题要求还原路径,邻接表麻烦的一笔且确实数据不大+密集图,就还是用的邻接矩阵

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<queue>

using namespace std;

const int inf = 1e9 + 10;
const int MAXN = 110;
struct node
{
	int in[MAXN];
	int out[MAXN];
	int flow;
}a[MAXN];
int G[MAXN][MAXN], copy_G[MAXN][MAXN], used[MAXN], layer[MAXN];
int n, p;
void chushi()
{
	memset(G,0,sizeof(G));
	memset(copy_G, 0, sizeof(copy_G));
	for(int i = 1; i <= p; i ++)
	{
		a[1].in[i] = a[1].out[i] = 0;
		a[n + 2].in[i] = a[n + 2].out[i] = 1;
	}
	a[1].flow = a[n + 2].flow = inf;
}
int canLink(node u, node v)
{
	for(int i = 1; i <= p; i ++)
	{
		if(u.out[i] != v.in[i] && v.in[i] != 2)
			return 0;
	}
	return 1;
}
int bfs(int Start, int End)
{
	memset(used, 0, sizeof(used));
	memset(layer, -1,sizeof(layer));
	queue<int>que;
	used[Start] = 1; layer[Start] = 0;
	que.push(Start);
	while(!que.empty())
	{
		int u = que.front();
		que.pop();
		if(u == End)
			return 1;
		for(int i = 1; i <= End; i ++)
		{
			if(G[u][i] && !used[i])
			{
				layer[i] = layer[u] + 1;
				used[i] = 1;
				que.push(i);
			}
		}
	}
	return 0;
}
int dfs(int u, int Max_Flow, int End)
{
	if(u == End)
		return Max_Flow;
	int uFlow = 0;
	for(int i = 1; i <= End; i ++)
	{
		if(layer[i] == layer[u] + 1 && G[u][i])
		{
			int flow = min (Max_Flow - uFlow, G[u][i]);
			flow = dfs(i, flow, End);
			G[u][i] -= flow;
			G[i][u] += flow;
			uFlow += flow;
			if(uFlow == Max_Flow)
				break;
		}
	}
	return uFlow;
}
int dinic(int Start, int End)
{
	int Max_Flow = 0;
	//cout << "!" << endl;
	while(bfs(Start, End))
	{
		//cout <<"!!" << endl;
		Max_Flow += dfs(Start, inf, End);
	}
	//cout <<"!!"<<endl;
	return Max_Flow;
}
int main()
{
	while(~scanf("%d %d", &p, &n))
	{
		chushi();
		for(int i = 2; i <= n + 1; i ++)
		{
			scanf("%d", &a[i].flow);
			for(int j = 1; j <= p; j ++)
				scanf("%d", &a[i].in[j]);
			for(int j = 1; j <= p; j ++)
				scanf("%d", &a[i].out[j]);
		}
		n += 2;
		for(int i = 1; i <= n; i ++)
		{
			for(int j = 1; j <= n; j ++)
			{
				if(i == j)
					G[i][j + n] = copy_G[i][j + n] = a[i].flow;
				else if(i != j && canLink(a[i], a[j]))
					G[i + n][j] = copy_G[i + n][j] = a[i].flow;
			}
		}
		int Max_Flow = dinic(1, n << 1);
		int k = 0, u[MAXN], v[MAXN], w[MAXN];
		for(int i = 2; i < n; i ++)
		{
			for(int j = 2; j < n; j ++)
			{
				if(G[i + n][j] < copy_G[i + n][j])
				{
					u[k] = i; v[k] = j; w[k ++] = copy_G[i + n][j] - G[i + n][j];
				}
			}
		}
		printf("%d %d\n", Max_Flow, k);
		for(int i = 0; i < k; i ++)
		{
			printf("%d %d %d\n", u[i] - 1, v[i] - 1, w[i]);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值