Aaronson(贪心)

Aaronson(贪心)

Recently, Peter saw the equation x0 +2x1+4x2+…+2mxm=n. He wants to find a solution (x0,x1,x2,…,xm) in such a manner that ∑i=0mxi (x0到xm的和)is minimum and every xi (0≤i≤m) is non-negative.

Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:
The first contains two integers n and m (0≤n,m≤109).

Output
For each test case, output the minimum value of ∑i=0mxi.

Sample Input
10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3

Sample Output
1
2
2
3
2
2
3
2
3
2

题意: x0 +2x1+4x2+…+2mxm=n,给你n,m,求的x0到xm的和的最小值

思路: 贪心,每次减去最大的,2n越大,xn越小

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int a[1100];
int main()
{
	int t,n,m,i,j,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		k=m;//如果没有a[i]>=n就直接从m开始遍历
		for(i=0;i<=m;i++)
		{
			a[i]=pow(2,i);//系数 
			if(a[i]>=n)
			{
				k=i;
				break;
			}
		}
		int ans=0;
		for(i=k;i>=0;i--)
		{
			if(n>=a[i])
			{
				ans+=n/a[i];//ans表示用了ans个a[i],即x 
			//	printf("%d++\n",ans); 
				n=n%a[i];//剩余的 
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值