Fire Net(深搜/二分匹配)

Fire Net (深搜/二分匹配)

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
在这里插入图片描述

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input
4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0

Sample Output
5
1
5
2
4

题意: 给定一个图,X为炮台,.为平地,要求放入最多数量的碉堡,并且碉堡之间不能相互攻击,碉堡可以向四个方向攻击,但是不能穿过墙。

思路: 两种方法,第一种也是我看到这个题的第一想法深搜,搜格子,从第一个格子到最后一个格子,赋予编号,从1到n*n,然后判断这个格子是否能放碉堡,能的话,就把这个格子标为‘1’或别的与原图不一样的字符,搜到最后一个格子为止
第二种,二分匹配,那我们就得先建图了,从1开始,中间有隔墙+1,换行或者换列+1,这些数字表示第几个碉堡可能放在他所在的这个格子中


在这里插入图片描述

在这里插入图片描述
图片来自这里

这样的话,每中数字代表的地方就只能安置一个碉堡,就转化成了二分图匹配求最大匹配

AC代码:

深搜

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[1100][1100];
int n,ans;
int check(int x,int y)
{
	int i;
	for(i=x-1;i>=0;i--)//上 
	{
		if(a[i][y]=='1')//上方有一个碉堡
		return 0;
		if(a[i][y]=='X')//到墙可提前截至 
		break; 
	}
	for(i=y-1;i>=0;i--)//左
	{
		if(a[x][i]=='1')//前方有一个碉堡
		return 0;
		if(a[x][i]=='X')//到墙可提前截至 
		break; 
	 } 
	 return 1; 
 } 
void dfs(int g,int s)//g代表在那个格子,一共n*n个 
{
	if(g==n*n)
	{
		if(s>ans)
		ans=s;
		return ;
	}
	int x,y;
	x=g/n;
	y=g%n;
	if(a[x][y]=='.'&&check(x,y))
	{
		a[x][y]='1';//'1'表示在这放了一个碉堡 
		dfs(g+1,s+1);//能放s+1,下一个格子g+1 
		a[x][y]='.';//还原 
	 } 
	dfs(g+1,s);//不能放,s不变 
}
int main()
{
	while(~scanf("%d",&n)&&n)
	{
		memset(a,0,sizeof(a));
		for(int i=0;i<n;i++)
		scanf("%s",a[i]);
		ans=0;
		dfs(0,0);
		printf("%d\n",ans);
	}
	return 0;
}

二分匹配

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,book1[1100][1100],book2[1100][1100];
int e[1100][1100],book[1100],match[1100];
int k1,k2;
char a[1100][1100];
int dfs(int x)
{
	int i;
	for(i=1;i<=k2;i++)
	{
		if(e[x][i]&&!book[i])
		{
			book[i]=1;
			if(!match[i]||dfs(match[i]))
			{
				match[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	while(~scanf("%d",&n)&&n)
	{
		memset(book1,0,sizeof(book1));
		memset(book2,0,sizeof(book2));
		memset(match,0,sizeof(match));
		memset(a,0,sizeof(a));
		memset(e,0,sizeof(e));
		int i,j;
		for(i=0;i<n;i++)
		scanf("%s",a[i]);
		k1=0;//建图
		for(i=0;i<n;i++)//行
		{
			for(j=0;j<n;j++)
			{
				while(a[i][j]=='X'&&j<n)
				j++;
				k1++;
				while(a[i][j]=='.'&&j<n)
				{
					book1[i][j]=k1;
					j++;
				}	
			}
		}
		k2=0;
		for(i=0;i<n;i++)//列
		{
			for(j=0;j<n;j++)
			{
				while(a[j][i]=='X'&&j<n)
				j++;
				k2++;
				while(a[j][i]=='.'&&j<n)
				{
					book2[j][i]=k2;
					j++;
				}
			}
		}
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				if(a[i][j]=='.')
				e[book1[i][j]][book2[i][j]]=1;
		int ans=0;
		for(i=1;i<=k1;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
			ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值