Cow Contest(floyd传递闭包)

Cow Contest (floyd传递闭包)

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5

Sample Output
2

题意: 一群牛比赛,两只一比,前者为赢家,问有几头牛可以确定名次

思路: 有向,首先我们要把这几场比赛的结果连起来形成一个图,确定牛与牛之间是否有关系,这里我用的floyd的变形,然后判断他与其他所剩牛是否都有联系,都有就能确定名次

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
int e[1100][1100];
int main()
{
	int n,m,a,b,i,j,k;
	scanf("%d%d",&n,&m);
	memset(e,0,sizeof(e));
	while(m--)
	{
		scanf("%d%d",&a,&b);
		e[a][b]=1;
	}
	for(k=1;k<=n;k++)
	for(i=1;i<=n;i++)
	for(j=1;j<=n;j++)
	if(e[i][k]&&e[k][j])//ab有关系,bc有关系,则ac有关系 
	e[i][j]=1;
	int ans=0;
	for(i=1;i<=n;i++)
	{
		int sum=0;
		for(j=1;j<=n;j++)
		{
			if(i==j)
			continue;//这头牛与其他所有牛都有联系才能确定名次 
			if(e[i][j]==0&&e[j][i]==0)//有一头没联系就可以跳出 
			break;
		}
		if(j>n)
		ans++;
	}
	printf("%d\n",ans);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值