1007. Maximum Subsequence Sum (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1007

题目:

 
 
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

分析:

最大子串和可以用Kadane算法在O(n)的时间内找到其最大字串和,但是不能找到其位置,这里我采用了一个比较巧妙的办法,记录其末尾位置,然后再从倒序遍历,就可以得到其首位的位置。
另外还要注意题目中提到如果输入的数据都为负数,则输出0 最先元素 最后元素,所以也要考虑到。

关于最长子串和的分析可以看http://wenchao.wang/?p=700
上面有很详细的关于最长子串和的三种算法的分析和过程


我自己写的代码:
找出最大字串和的代码如下:

#include<stdio.h>
int main(void){
 freopen("F://Temp/input.txt", "r", stdin);
 int input[100];
 int n;
 scanf("%d", &n);
 for (int i = 0; i < n; i++){
  scanf("%d", &input[i]);
 }
 int sum = 0;
 int max = 0;
 for (int i = 0; i < n; i++){ //核心代码-start-----------
  sum += input[i];
  if (sum > max)
   max = sum;
  else if (sum < 0)
   sum = 0;
 } //核心代码------end---------------------
 printf("%d\n", max);
 return 0;
}

而注意到上述算法并不能记录其最长子串和所在的位置,经过改编后,是可以记录的,不过需要遍历两次,时间复杂度还是O(n)

AC的代码:

#include<iostream>
using namespace std;
int a[10001];
int main(void){
 int i,j,n;
 while(scanf("%d",&n) != EOF){
  if(n == -1)break;
  for(i = 0; i < n; i ++){
   scanf("%d", &a[i]);
  }
  bool neg_flag = true;//是否都为复数的标志
  for(i = 0; i < n; i ++){
   if(a[i] >= 0){
    neg_flag = false;
    break;
   }
  }
  if(neg_flag){
   printf("0 %d %d\n",a[0],a[n - 1]);
   continue;
  }//如果都为负,则输出最先和最后元素,并定义max = 0。
  int start, end;//首尾两个坐标
  int max = -1,temp_sum = 0;
  for(i = 0; i < n; i ++){
   temp_sum += a[i];
   if(temp_sum > max){
    max = temp_sum;
    end = i;//记录最大子串和的最后一个坐标
   }
   else if(temp_sum < 0)
    temp_sum = 0;
  }
  max = -1,temp_sum = 0;
  for(i = end; i >= 0; i --){
   temp_sum += a[i];
   if(temp_sum > max){
    max = temp_sum;
    start = i;//再倒序遍历,找到最大子串和的第一个坐标
   }
  }
  printf("%d %d %d\n",max,a[start],a[end]);
 }
 return 0;
}



P.S:

其实很多PAT或者机试的题目,除了一些数学问题,其他很多都是经过经典算法的改编或拓展,把这些经典算法的原理和应用场景弄懂,而不是死记硬背,这样就能举一反三,得心应手,并且相应的时间空间复杂度也都会是接近最优。

——Apie陈小旭


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值