题目链接:http://www.patest.cn/contests/pat-a-practise/1024
题目:
1024. Palindromic Number (25)
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.
Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
Sample Input 1:67 3Sample Output 1:
484 2Sample Input 2:
69 3Sample Output 2:
1353 3
分析:
题目基于一个事实,任何一个数,如果本身不是回文数字,那么把自己反转再加上自己,经过有限步后,会变成一个回文数。那么主要是写两个函数:
1)判断是否是回文
2)反转自加的函数
AC代码:
#include<stdio.h>
#include<string.h>
using namespace std;
char str1[50];
char str3[50];
bool isPalin(char* str){//判断是否是回文
int i;
for (i = 0; str[i] != 0; i++);
for (int j = 0; j <= i; j++){
if (str[--i] != str[j])return false;
}
return true;
}
void add(char* str_a,char* str_sum){//反转自加
int i;
for (i = 0; str_a[i] != 0; i++);
int a, b, sum, jin = 0;
int j;
for (j = 0; j < i; j++){
a = str_a[j] - '0';
b = str_a[i - 1 - j] - '0';
sum = a + b + jin;
jin = sum / 10;
str_sum[j] = sum % 10 + '0';
}
if (jin != 0)
str_sum[j++] = jin + '0';
j--;
for (int w = 0; w <= j / 2; w++){
char temp = str_sum[w];
str_sum[w] = str_sum[j - w];
str_sum[j - w] = temp;
}
return ;
}
int main(void){
int k;
while (scanf("%s%d", str1, &k) != EOF){
int count = 0;
strcpy(str3, str1);
for (; count < k; count++){
if (isPalin(str3) == true){
break;
}
else{
add(str1,str3);
strcpy(str1, str3);
}
}
puts(str3);
printf("%d\n", count);
}
return 0;
}
截图:
——Apie陈小旭
希望妈妈快点好起来