1024 Palindromic Number (25 分)(大数相加)

1024 Palindromic Number (25 分)(大数相加)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​ ) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
分析

本题考查的是数的相加和逆序,本属于简单题,但是本质考查了大数相加的知识。第一次提交时未注意到大数相加,测试点6和测试点8(从0开始)未通过,然后在看博客1才意识到考查大数相加,理由是本题的N的范围是(0,1010],k的范围是(0,100],我们考虑最坏的情况,假设N是一个非常逼近1010的值并且进行了100步操作依然未得到回文值,则简单推测可知计算过程中遇到的最大值是2100*1010,这个值超出了long long int(263-1,约9.2*1018)表示范围,因此需要用string存储数的值。

#include <iostream>
#include <algorithm>
using namespace std;
string add(string a){
    string ans=a;
    reverse(a.begin(),a.end());
    int i=a.length()-1,add=0;
    while(i>=0){
        int tmp=a[i]-'0'+ans[i]-'0';
        ans[i]=(add+tmp)%10+'0';
        add=(tmp+add)/10;
        i--;
    }
    if(add) ans.insert(0,"1");
    return ans;
}
int main(){
    string s;
    int k;
    cin>>s>>k;
    string tmp=s;
    reverse(tmp.begin(),tmp.end());
    if(tmp==s) cout<<tmp<<endl<<0;
    else{
        int i=0;
        while(i<k){
            s=add(tmp);
            i++;
            tmp=s;
            reverse(tmp.begin(),tmp.end());
            if(tmp==s) break;
        }
        cout<<s<<endl<<i;
    } 
    return 0;
}

  1. https://www.liuchuo.net/archives/2329 ↩︎

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值