1030. Travel Plan (30)

题目链接:http://www.patest.cn/contests/pat-a-practise/1030

题目:

1030. Travel Plan (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

分析:

因为已经有唯一最短路径的保证了,不用记录多条路径(这个有难度)。典型的最短路径,不过在最短distance路径基础上增加了cost,并且还要记录路径,所以增加一个path[]来记录前面的父节点,以及distance之后cost的判断。

AC代码:

#include<stdio.h>
using namespace std;
int distance[501][501];//记录直连各段路径的distance
int cost[501][501];//记录直连各段路径的cost
int Dis[501];//记录起点到各个点的距离
int Cost[501];//记录起点到各个点cost
bool mark[501];//记录是否已经加入了dijkstra算法的最短点集合中
int path[501];//记录父节点,所以父节点倒序连起来就是最短路径的各个节点
int main(void){
 //freopen("F://Temp/input.txt", "r", stdin);
 int n, m, s, t;
 scanf("%d%d%d%d", &n, &m, &s, &t);
 for (int i = 0; i < n; i++){
  for (int j = 0; j < n; j++){
   distance[i][j] = 0;
   cost[i][j] = 0;
  }
  Cost[i] = 0;
  Dis[i] = 0;
  mark[i] = false;
  path[i] = -1;
 }//init
 for (int i = 0; i < m; i++){
  int a, b, dis, c;
  scanf("%d%d%d%d", &a, &b, &dis, &c);
  distance[a][b] = distance[b][a] = dis;
  cost[a][b] = cost[b][a] = c;
 }
 int newP = s;
 mark[newP] = true;
 Cost[newP] = 0;
 Dis[newP] = 0;
 path[newP] = 0;
 while (!mark[t]){
  for (int i = 0; i < n; i++){
   if (mark[i] || distance[newP][i] == 0)continue;
   else if (Dis[i] == 0 || Dis[i] > Dis[newP] + distance[newP][i] || Dis[i] == Dis[newP] + distance[newP][i] && Cost[i] > Cost[newP] + cost[newP][i]){
    Dis[i] = Dis[newP] + distance[newP][i];
    Cost[i] = Cost[newP] + cost[newP][i];
    path[i] = newP;
   }
  }
  int min_dis = 0x7fffffff;
  int min_cost = 0x7fffffff;
  for (int i = 0; i < n; i++){
   if (mark[i] || Dis[i] == 0)continue;
   if (Dis[i] < min_dis || Dis[i] == min_dis && Cost[i] < min_cost){
    min_dis = Dis[i];
    min_cost = Cost[i];
    newP = i;
   }
  }
  mark[newP] = true;
 }//while
 int ans[501];
 int i = 0;
 for (int k = t; path[k] != s; i++, k = path[k]){
  ans[i] = path[k];
 }
 printf("%d", s);
 for (int j = i - 1; j >= 0; j--){
  printf(" %d", ans[j]);
 }
 printf(" %d %d %d\n", t,Dis[t],Cost[t]);
 return 0;
}


截图:


——Apie陈小旭

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该信息出现的原因是因为在映射文件中找不到com.travel.travel.mapper.UserMapper.findAll这个绑定的语句。根据引用提供的信息,你需要在Java的配置文件中创建一个包,将你的mapper映射文件放进去,并且要注意包名与你的mapper接口的包名要一致。另外,根据引用提供的信息,你还需要在pom.xml文件中加入一些配置,以确保资源和代码文件被正确加载。最后,根据引用提供的信息,你可以下载一个提供者和消费者模块的示例代码进行学习,并在http://127.0.0.1:8083/user/getUser这个地址上进行简单的调用。这些步骤和配置可以帮助你解决Invalid bound statement (not found)的问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [Invalid bound statement (not found): com.itheima.mapper.userMapper.SelectAll](https://blog.csdn.net/weixin_64773406/article/details/127726908)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *3* [plan_project.zip](https://download.csdn.net/download/weixin_39846786/12233758)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值