1038. Recover the Smallest Number (30)

题目链接:http://www.patest.cn/contests/pat-a-practise/1038

题目:

1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

分析:

输出几个数字字符串,输出其组合数的最小值,最简单的当然是穷举然后排序了,但是太暴力了,我们要反对暴力。

应该先对字符串进行一个排序,然后直接组合后输出即可。这里的比较函数是一个难点。

注意到234<2343, 234 > 2341,所以如果两个字符串比较,较短字符串比较完后还要进行循环比较直到较长字符的末尾(即要取%接着比较)

要注意输入都为0的情况。也注意一下string的erase的用法

AC代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string>
#include<vector>
using namespace std;
vector<string>V;
bool cmp1(string A, string B){//核心的比较函数
 if (A.size() > B.size()){
  for (int i = 0; i < A.size(); i++){
   if (A[i] != B[i % B.size()])//当较短字符串比较完了之后,还要循环继续比较到较长字符串的末尾,因为234是小于2343的,但是是大于2341的。
    return A[i] < B[i % B.size()];
  }
 }
 else{
  for (int i = 0; i < B.size(); i++){
   if (A[i % A.size()] != B[i])
    return A[i % A.size()] < B[i];
  }
 }//make sure that A is no longer than B
}
int main(){
 //freopen("F://Temp/input.txt", "r", stdin);
 string tmp;
 int n;
 cin >> n;
 for (int i = 0; i < n; i++){
  cin >> tmp;
  V.push_back(tmp);
 }
 sort(V.begin(), V.end(), cmp1);
 string str;
 for (int i = 0; i < V.size(); i++){
  str += V[i];
 }
 int idx = 0;
 while (str[idx] == '0')idx++;
 str.erase(0, idx);//要把首部的0给去除掉
 if (str.size() == 0)cout << "0" << endl;//如果一个数字也没有,输出0
 else cout << str << endl;
 return 0;
}


截图:


——Apie陈小旭

ECDSA.recover is a function in the ECDSA (Elliptic Curve Digital Signature Algorithm) cryptographic system that allows a user to recover the public key from a given signature and message. This function is useful in situations where the public key is unknown but the signature and message are available. The ECDSA algorithm involves three steps: key generation, signature generation, and signature verification. In the key generation step, a private key is generated using a random number generator, and the corresponding public key is derived from the private key. In the signature generation step, a message is hashed and signed using the private key to generate a signature. In the signature verification step, the signature is verified using the public key to ensure that it was generated by the owner of the private key. In some cases, the public key may not be available, but the signature and message are known. In such cases, the ECDSA.recover function can be used to recover the public key from the signature and message. The function takes three inputs: the message, the signature, and the recovery parameter. The recovery parameter is a number between 0 and 3 that specifies which of the four possible public keys should be recovered from the signature. Once the public key is recovered, it can be used to verify the signature and authenticate the message. Overall, ECDSA.recover is a useful function in the ECDSA cryptographic system that allows for public key recovery in situations where it is unknown but the signature and message are available.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值