1101. Quick Sort (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1101
题目:

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

    Hence in total there are 3 pivot candidates.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:
    5
    1 3 2 4 5
    
    Sample Output:
    3
    1 4 5

分析:
快排的一个很重要的特性就是在一次排序过后,作为pivot轴的元素(1)就到达了它的正确位置,(2)它左边的数字都比它小,它右边的元素都比它大。
很多人可能一看到这个题目就想我先排序一下,然后比较各个位数的数字是否和原数组中的一样,这样的解法只满足了(1),却没有满足(2),如果加上位置对的元素的左边和右边的大小比较来满足(2),却又会超时,因为这样的复杂度在最差的时候能够达到O(n2)。
正确的方法应该是用 DP动态规划来做,先从前向后遍历一遍,存储头到当前节点的最大值dp1[i],再从后向前遍历一遍,存储尾到当前节点的最小值dp2[i]。
最后,如果一个元素大于dp1[i - 1]并且小于dp[i + 1],相当于在它左边的都比它小,在它右边的都比它大,那么它就在正确的位置上。
比如题目中的例子:
原数组:1 3 2 4 5
dp1[i]: 1 3 3 4 5
dp2[i]: 1 2 2 4 5
满足?: t  f f t t
所以结果是1 4 5
另外,题目中的一个坑就是如果遇到没有元素满足时,要输出一个0和两个回车,(测试点3),不然会有格式错误。

AC代码:
#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main(){
 //freopen("F://Temp/input.txt", "r", stdin);
 int n;
 const int SUM = 100002;
 int dp1[SUM];//记录从头到当前节点的最大值
 int dp2[SUM];//记录从尾到当前节点的最小值
 int buf[SUM];//记录输入的数据
 bool mark[SUM]; //记录数据是否在其正确的位置上
 while (cin >> n)	{
  for (int i = 1; i <= n; ++i)	 {
   int t;
   cin >> t;
   buf[i] = t;
   dp1[i] = dp2[i] = t;
   mark[i] = false;
  }
  dp1[0] = -0x7fffffff;//设置左边为最小值,这样可以让边界dp1[1]判断
  dp2[n + 1] = 0x7fffffff;//设置右边为最大值,方便尾判断
  for (int i = 2; i <= n; ++i){//找出从头到当前节点的最大值
   dp1[i] = max(dp1[i], dp1[i - 1]);
  }
  for (int i = n - 1; i >= 0; --i)//找出从头到当前节点的最小值
   dp2[i] = min(dp2[i], dp2[i + 1]);
  for (int i = 1; i <= n; ++i)//该点左边的都小于它,右边的都大于它
  if (buf[i] > dp1[i - 1] && buf[i] < dp2[i + 1])
   mark[i] = true;
  int cnt = 0;
  for (int i = 1; i <= n; ++i)
  if (mark[i] == true)
   cnt++;
  cout << cnt << endl;
  for (int i = 1; i <= n; ++i){
   static bool flag = true;
   if (mark[i]){//这里要注意,不能用i == 1来判断,因为第一个不一定mark成功
    if (flag){
     cout << buf[i];
     flag = false;
    }
    else
     cout << " " << buf[i];
   }
  }
 }
 cout << endl;//这里一定要加一个回车,不然测试点3通不过(是个0个成功的测试)
 return 0;
}


截图:

——Apie陈小旭
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值