程序设计基础58 递推非暴力

1101 Quick Sort (25 分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

一,关注点

1,像这种题目,数组长度为10^5,for循环遍历整个数组的时候就不能再嵌套一个for循环遍历了。最好的方法是整体遍历一遍,用递推方法打好表,直接从表中获取答案。同样问题见A1093,数PAT数目的那道题。

2,就算是主元数目为0第二行也要输出一个空行,所以别忘了在最后要换行。

二,我的代码

#include<cstdio>
#include<algorithm>
using namespace std;
const int MIN_INF = -0x7fffffff;
const int MAX_INF = 0x7fffffff;
const int max_n = 100100;
int arr[max_n];
bool left_compare[max_n] = { false };
bool right_compare[max_n] = { false };
int ans[max_n];
bool cmp(int a, int b) {
	return a < b;
}
int main() {
	int num = 0;
	int N = 0;
	int max_num = MIN_INF;
	int min_num = MAX_INF;
	scanf("%d", &N);
	for (int i = 0; i < N; i++) {
		scanf("%d", &arr[i]);
		if (arr[i] > max_num) {
			max_num = arr[i];
			left_compare[i] = true;
		}
	}
	for (int i = N - 1; i >= 0; i--) {
		if (arr[i] < min_num) {
			min_num = arr[i];
			right_compare[i] = true;
		}
	}
	for (int i = 0; i < N; i++) {
		if (left_compare[i] && right_compare[i]) {
			ans[num++] = arr[i];
		}
	}
	printf("%d\n", num);
	sort(ans, ans + num, cmp);
	for (int i = 0; i < num; i++) {
		printf("%d", ans[i]);
		if (i != num - 1) {
			printf(" ");
		}
	}
	printf("\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值