最短路径-Dijkstra算法总结(附题:HDU-1548 A strange lift)

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17554    Accepted Submission(s): 6559

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5 3 3 1 2 5 0

Sample Output
3

关于用Dijkstra算法求单源最短路径,我简单总结下解题的基本步骤:
1.初始化邻接矩阵的值;
2.输入每条边的权值;
3.初始化起点到各边的距离;
4.利用book数组判定是否与原点相连;
5.Dijkstra算法。

算法的核心代码:

for (i = 1; i <= n-1; i++)
{
    min = inf;
	for (j = 1; j<= n; j++)
	{
		if (book[j] == 0 && dis[j] < min)//这里判断是否和1顶点相连
		{
			min = dis[j];
			u = j;
		}
	}
	book[u] = 1;
	for (v = 1; v <= n; v++)
	{
		if (e[u][v] < inf)//这里判断最短距离
		{
			if (dis[v]>dis[u] + e[u][v])
			{
				dis[v] = dis[u] + e[u][v];
			}
		}
	}
}

这道题的题目意思是:有一个N层电梯,对于每层楼都有一个数字Ki(i代表不同楼层),在电梯里只有两个按钮,上或者下。如果你现在位于第i层楼(对应数字为Ki),如果按下了Up,电梯就会上i+Ki楼,如果按下了Down,电梯就会到i-Ki楼。当然,电梯不会上到超过N层楼,也不会下过一楼。问题是,如果你现在在A层楼,想去B层楼,至少需要按多少次Up或者Down才能到达目的地。

其实,如果把每层楼看成一个节点,令每条边(每两层楼)的权值为1,并且是单向边,这样就可以转化成最短路径问题。

附上AC代码:

#include<stdio.h>
int e[205][205],dis[205],book[205],k[205],N,A,B,k1,i,j,v,u,min;
int inf=999999;
void dijkstra(int s)
{
	for(i=1;i<=N;i++)
	{
		dis[i]=e[s][i];
		book[i]=0;
	}
	dis[s]=0;
	book[s]=1;
	for(i=1;i<=N-1;i++)
	{
		min=inf;
		for(j=1;j<=N;j++)
		{
			if(book[j]==0&&dis[j]<min)
			{
				min=dis[j];
                u=j;
			}
		}
		book[u]=1;
		for(v=1;v<=N;v++)
		{
			if(e[u][v]<inf)
				if(dis[v]>dis[u]+e[u][v])
					dis[v]=dis[u]+e[u][v];
		}

	}
}
int main()
{
	while(~scanf("%d %d %d",&N,&A,&B)&&N!=0&&A!=0&&B!=0)
	{
		for(i=1;i<=N;i++)
			for(j=1;j<=N;j++)
				if(i==j)
					e[i][j]=0;
				else
					e[i][j]=inf;
		for(i=1;i<=N;i++)
			scanf("%d",&k[i]);
	    for(i=1;i<=N;i++)
		{
			if(i+k[i]<=N)
				e[i][i+k[i]]=1;//必须是单向边!
			if(i-k[i]>=1)
				e[i][i-k[i]]=1;
		}
		dijkstra(A);
		if(dis[B]<inf)
		    printf("%d\n",dis[B]);
		else
			printf("-1\n");
		
	}
	return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值