ZOJ 3141 Arnie's Dog Biscuits【dp递推】

Arnie's Dog Biscuits

Time Limit: 1 Second       Memory Limit: 32768 KB

Our discerning gourmet puppy Arnie is turning to you for a program to help him split his dog biscuits. Each biscuit is shaped like a rectangle and perforated into equal sized squares:

Unfortunately, Arnie will only eat square-shaped biscuits; therefore, he must break the biscuit into squares. Each break, termed a split, is applied to one rectangle, runs along one straight perforated line, and separates the rectangle into two pieces:

Input

The first line of the input contains one positive integer n, the number of biscuits to split. Each of the next n lines contains two positive integers r and c, the number of rows and columns of one biscuit, separated by white space.

Output

The output contains one line for each biscuit specifying the minimal number of splits required to break the biscuit into squares.

Sample Input

2
6 7
5 5

This defines two biscuits: the one shown above which requires four splits, and a square biscuit which requires no splits.

Sample Output

4
0

dp[i][j]=min(dp[r][j]+dp[i-r][j]+1, dp[i][k]+dp[i][j-k]+1) 

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;

const double pi = acos(-1.0);
const int mod = 1e9 + 7;
const int maxn = 1e5 + 5;

int dp[1100][1100];

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

    int n, m;
    ms(dp, INF);
    for (int i = 0; i <= 250; i++)
    {
        dp[i][i]=0;
        dp[i][0]=0;
        dp[0][i]=0;
    }
    for (int i = 1; i <= 250; i++)
    {
        for (int j = 1; j <= 250; j++)
        {
            for (int k = 0; k <= i; k++)
            {
                dp[i][j] = min(dp[i][j], dp[k][j] + dp[i - k][j] + 1);
            }
            for (int k = 0; k <= j; k++)
            {
                dp[i][j] = min(dp[i][j], dp[i][k] + dp[i][j - k] + 1);
            }
        }
    }

    int t;
    scanf("%d", &t);
    while (t--)
    {
        int n, m;
        scanf("%d%d", &n, &m);
        printf("%d\n", dp[n][m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值