A Simple Problem with Integers POJ - 3468(add增加模式改变一整段的值)

A Simple Problem with Integers POJ - 3468
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <map>
//#include <bits/stdc++.h>
using namespace std;
//const double eps = 1e-6;
//const double pi = acos(-1.0);
//const int INF = 0x3f3f3f3f;
//const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010

struct node
{
    int l,r;
    ll s,add;//add为每次加的数,这里需要longlong 可能超出int
} t[MAXN<<2];
int hh[MAXN];
int n,q;
ll ans;

void build(int l, int r, int i)
{
    //先构造好整树的大致框架,具体数据后面再填入
    t[i].l = l;
    t[i].r = r;
    t[i].add = 0;
    if(l == r) return ;
    int mid = (l+r)>>1;  //>>1代表/2,<<2代表*2
    build(l, mid, i<<1);
    build(mid+1, r, i<<1|1);//代表*2+1
    //  t[i].s = t[i<<1].s+t[i<<1|1].s;
}

void update(int l, int r, int add, int i)
{
    if(t[i].l>r || t[i].r<l) return ;//如果在l,r之外直接返回
    if(t[i].l>=l && t[i].r<=r)
    {
        //在这之间的话,就让现在的s+上需要增加的add
        //注意是r-l,它的下属(l=r的情况)有几个就增加几个
        t[i].s += (t[i].r-t[i].l+1)*add;
        //然后标记这里的i的add增加的数量
        t[i].add += add;
        //最后return,也就是下面那个if也不进行了,
        return ;
    }
    if(t[i].add)
    {
        //如果这个i的add存在,这也说明此处i的l和r不完全在
        //l,r之间,然后把这个i的add分给下级,因为它的下级可能
        //在lr之间,这个时候就需要让它的下级的add也增加
        t[i<<1].s += (t[i<<1].r-t[i<<1].l+1)*t[i].add;
        t[i<<1].add += t[i].add;
        t[i<<1|1].s += (t[i<<1|1].r-t[i<<1|1].l+1)*t[i].add;
        t[i<<1|1].add += t[i].add;
        //最后把这个i的add清零,放在重复给下级
        t[i].add = 0;
    }
    //遍历每一个
    update(l, r, add, i<<1);
    update(l, r, add, i<<1|1);
    //让这个的s等于下属俩的之和
    t[i].s = t[i<<1].s+t[i<<1|1].s;
}

void query(int l, int r, int i)
{
    //和上面那个update差不多
    if(t[i].l>r || t[i].r<l) return ;
    if(t[i].l>=l && t[i].r<=r)
    {
        //只不过这里上面是修改了树,现在只需要记录值就ok
        ans += t[i].s;
        return ;
    }
    if(t[i].add)
    {
        //这里为什么还要有这个if呢,因为上面更新的时候,
        //可能只让这个树中间的某个add赋予值了,它的儿子们没有
        //赋予值,因为更新的时候可能这个i的l-r正好在那个l,r之间
        //那么上面那个update直接return了,没有对儿子们进行操作
        //这里求和的时候,可能这个add存在的i的l-r只是l-r中的一部分在
        //l,r之间,所以就需要把这个add向下传;
        // printf("l=%d r=%d\n",t[i].l,t[i].r);
        //printf("add=%lld\n",t[i].add);
        t[i<<1].s += (t[i<<1].r-t[i<<1].l+1)*t[i].add;
        t[i<<1].add += t[i].add;
        t[i<<1|1].s += (t[i<<1|1].r-t[i<<1|1].l+1)*t[i].add;
        t[i<<1|1].add += t[i].add;
        t[i].add = 0;
    }
    query(l, r, i<<1);
    query(l, r, i<<1|1);
    t[i].s = t[i<<1].s+t[i<<1|1].s;
}

int main()
{
    int a,b,c;
    //ll k;
    char ch;
    while(scanf("%d%d",&n,&q)==2)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&hh[i]);
        build(1, n, 1);//这里建好大致结构后还没有赋值
        for(int i=1; i<=n; i++)//对建好的树进行初步赋值
            update(i, i, hh[i], 1);
        /*  for(int i=1;i<50;i++)
              printf("%lld\n",t[i].add);*/
        while(q--)
        {
            getchar();
            scanf("%c",&ch);
            if(ch == 'C')
            {
                scanf("%d%d%d",&a,&b,&c);
                update(a, b, c, 1);
            }
            if(ch == 'Q')
            {
                ans = 0;
                scanf("%d%d",&a,&b);
                query(a, b, 1);
                printf("%lld\n",ans);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值