PAT 1008(简单数学)

1008 Elevator (20分)


The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

一、试题分析:

本题题目意思是: 

  1. 上楼每层6s、下楼每层4s、到达则停5s
  2. 输入第一个数为N
  3. 后面继续输入N个数表示电梯到达的序列
  4. 输出总共花费时间

二、解题思路:

本题求解只需要:每次到达楼层比较上一楼层,如果上升按照上升要求计算,下降按照下降要求计算即可。

#include<iostream>
using namespace std;

int main() {

	int n;
	int next;
	int now = 0;
	int sum = 0;
	cin >> n;
	for (int i = 0; i < n ; i++) {
		cin >> next;
		if (next - now > 0) //上楼
			sum += (next - now) * 6+5;
		else //下楼
			sum += (now - next) * 4+5;
		now = next;
	}
	cout << sum;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值