Sicily 1561. PRIME

Time Limit: 1 secs, Memory Limit: 32 MB

Description

A prime number is a natural number which has exactly two distinct natural number divisors: 1 and itself. The first prime number is 2. Can you write a program that computes the nth prime number, given a number n <= 10000?

Input

The input contains just one number which is the number n as described above.
The maximum value of n is 10000.

Output

The output consists of a single line with an integer that is the nth prime number.

Sample Input

30
Sample Output

113


︿( ̄︶ ̄)︿ Just do it!

#include <iostream>
#include <cstring>
#include <vector>
#include <cmath>

using namespace std;

bool prime[110000];

void getPrime()
{
    memset(prime, true, sizeof(prime));
    // think about i < sqrt(110000)
    for (int i = 2; i < sqrt(110000); i++) {
        if (!prime[i])
            continue;
        else{
            for (int j = i * i; j < 110000; j += i)
                prime[j] = false;
        }
    }
}

int main()
{
    vector<int> op;
    int num, i = 2;
    getPrime();
    while (i < 110000) {
        if (prime[i])
            op.push_back(i);
        i++;
    }
    cin >> num;
    cout << op[--num] << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值