Sicily 2005. Lovely Number

Time Limit: 1 secs, Memory Limit: 64 MB

Description

Every time after got a solution from kevin, ivan repeats again and again,”Are there any better ones?”. It seems more worse this time. Given a sequence of numbers, which ivan is sure that all of them appear even times except only one “lovely number” appears odd times, kevin must find out the lovely number as soon as possible. So, let’s rock!

Input

There are multiple test cases.

Each test case contains two lines. The first line is an integer N, 1 <= N <= 10001, and N % 2 = 1. The second line contains N integers, separated by spaces.

Input is terminated by EOF.

Output

For each test case, output a line of an integer, which should be the lovely number.

Sample Input

3
1 2 1
5
7 7 7 7 3
7
2 2 4 4 4 2 2

Sample Output

2
3
4
Problem Source

2010中山大学新手赛-网络预选赛 ivankevin@argo


(。^▽^) Just do it!

#include <iostream>
#include <map>

using namespace std;

int main()
{
    map<int, int> Temp;
    int T, Tp;
    while (cin >> T)
    {
        Temp.clear();
        while (T--) {
            cin >> Tp;
            Temp[Tp]++;
        }
        map<int, int>::iterator i = Temp.begin();
        while (i != Temp.end()) {
            if ((*i).second % 2 == 1) {
                cout << (*i).first << endl;
                break;
            }
            i++;
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值