POJ 3264 Balanced Lineup //简单线段树

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 33405 Accepted: 15671
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

#include <stdio.h>

struct node 
{
	int l, r;
	int max, min;
}tree[200005];
int h[50004];
int max, min;

int MAX(int a, int b)
{
	if(a>b)
		return a;
	return b;
}
int MIN(int a, int b)
{
	if(a<b)
		return a;
	return b;
}

void build(int l, int r, int root)  //建树
{
	int mid;

	tree[root].l = l;		//将区间位置 赋给 树
	tree[root].r = r;

	if(l==r)
	{
		tree[root].max = tree[root].min = h[l];//当叶子结点区间长度为1时,赋值
		return ;
	}
	mid = (l + r)>>1;		//除2
	build(l, mid, 2*root);  	//建立左子树
	build(mid+1, r, 2*root+1);  //建立右子树
	
	tree[root].max = MAX(tree[root*2].max, tree[root*2+1].max);//当前结点的最大最小值等于他的 左子树与右子树 中的最大最小值。
	tree[root].min = MIN(tree[root*2].min, tree[root*2+1].min);
}
void findmax(int l, int r, int root)
{
	int mid;
	if(tree[root].l==l && tree[root].r==r)//当查找的区间与结点区间吻合时,这区间的最大最小值就是这个结点的最大最小值。
	{
		max = MAX(max, tree[root].max);
		min = MIN(min, tree[root].min);
		return ;
	}
	mid = (tree[root].l + tree[root].r)>>1;
	if(mid >= r)     //当查找的区间在此结点的 左子树时;
		findmax(l, r, root*2);
	else if(mid < l) //当查找的区间在此结点的 右子树时;
		findmax(l, r, root*2+1);
	else			//当查找的区间横跨此结点的 左右子树时;
	{
		findmax(l, mid, root*2);
		findmax(mid+1, r, root*2+1);
	}
}

int main()
{
	int n, q;
	int l, r;
	int i;

	scanf("%d%d", &n, &q);
	for(i=1; i<=n; i++)
		scanf("%d", &h[i]);
	build(1, n, 1);		//从第1个结点开始建树。

	while(q--)
	{
		scanf("%d%d", &l, &r);
		max = -0xfffff;			//赋初值
		min = 0xfffff;
		findmax(l, r, 1);	

		printf("%d\n", max-min);
	}

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值