Catch That Cow



Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 52614 Accepted: 16499
Description


Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.


* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.


If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?


Input


Line 1: Two space-separated integers: N and K
Output


Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input


5 17
Sample Output


4
Hint


The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source


USACO 2007 Open Silver

#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;

typedef struct pot{
    int x, num;
}pot;
int n, k;
bool rot[110000];

bool judge(pot x)
{
    if(x.x<0 || x.x>100000 || rot[x.x])   return false;

    return true;
}

int bfs()
{
    queue<pot>Q;
    pot now, next;
    now.x=n; now.num=0;
    if(!judge(now)) return 0;
    rot[now.x]=true;
    Q.push(now);
    while(!Q.empty()){
        now=Q.front(); Q.pop();
        if(now.x==k)   return now.num;

        next.x=now.x+1; next.num=now.num+1;
        if( judge(next) ){
            rot[next.x] = true;
            Q.push(next);
        }
        next.x=now.x-1; next.num=now.num+1;
        if( judge(next) ){
            rot[next.x] = true;
            Q.push(next);
        }
        next.x=now.x*2; next.num=now.num+1;
        if( judge(next) ){
            rot[next.x] = true;
            Q.push(next);
        }
    }
    return 0;
}

int main()
{
    int ans;
    while( scanf("%d%d",&n, &k)!=-1 ){
        memset(rot, false, sizeof(rot));
        ans = bfs();
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值