HDOJ<1062>Text Reverse

Text Reverse


  • Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.


-用java 捣鼓了挺久,最终也只是把结果成功输出来了,不过格式还是有点不对,先这样吧。。。



import java.util.Scanner;

public class Text_reverse {
    public static String Reverse(String s){   //单词反转函数
        int len=s.length();
        if(s.length()<=1)
            return s;
        String left=s.substring(0, len/2);
        String right=s.substring(len/2, len);
        return Reverse(right)+Reverse(left);
    }

    public static void main(String[] args) {
        // TODO 自动生成的方法存根
        Scanner in=new Scanner(System.in);
        while(in.hasNextInt()){
            int n=in.nextInt();
            in.nextLine();              //吸收掉\n
            for(int i=0;i<n;i++){
                String str=in.nextLine();
                String[] s=str.split(" ");
                for(int j=0;j<s.length;j++){
                    if(j!=s.length-1){
                        String ss=Reverse(s[j]);
                        System.out.print(ss+" ");
                    }
                    else{
                        String ss=Reverse(s[j]);
                        System.out.print(ss); 
                        System.out.println();
                    }
                }
            }
        }
    }

}

在网上查了一下c语言版本,想法真心不错。

#include<stdio.h>  
#include<string.h>  
int main()  
{  
    int i,n,len,j,k,t;  
    char s1[1005],s2[100];  
    scanf("%d",&n);  
    getchar();  
    while(n--)  
    {  
        gets(s1);  
        len=strlen(s1);  
        for(i=0,j=0,t=0;i<len;i++)  
        {  
            if(s1[i]!=' ')  
                s2[j++]=s1[i]; /*保存单词*/  
            else  
            {  
                if(t>0) printf(" "); /*控制格式*/  
                for(k=j-1;k>=0;k--)   
                    printf("%c",s2[k]); /*反转输出*/  
                j=0;  
                t++;  
            }  
            if(i==len-1) /*反转最后一个单词,这里要特别注意*/  
            {  
                printf(" ");  
                for(k=j-1;k>=0;k--)  
                    printf("%c",s2[k]);  
            }  
        }  
        printf("\n");  
    }  
    return 0;  
}  

  • 不过这种题目感觉用栈是最好的,因为题目要求符合栈先进后出的原则。
#include<iostream>
#include<stack>
using namespace std;
int main()
{
    int n;
    char ch;
    cin>>n;
    getchar();
    while(n--)
    {
        stack<char> s;   //定义栈 
        while(true)
        {
            ch=getchar();//压栈时,依次压入一个字符 
            if(ch==' '||ch=='\n'||ch==EOF)
            {
                while(!s.empty())
                {
                    cout<<s.top();
                    s.pop();       //清除栈顶元素 
                }
                if(ch=='\n'||ch==EOF)
                     break;
                cout<<" ";
            }
            else
            {
                s.push(ch);
            }
        }
        cout<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值