数据结构实验之串二:字符串匹配
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
给定两个字符串string1和string2,判断string2是否为string1的子串。
Input
输入包含多组数据,每组测试数据包含两行,第一行代表string1,第二行代表string2,string1和string2中保证不出现空格。(string1和string2大小不超过100字符)
Output
对于每组输入数据,若string2是string1的子串,则输出"YES",否则输出"NO"。
Example Input
abc a 123456 45 abc ddd
Example Output
YES YES NO
Hint
Author
赵利强
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char a[1000000+5], b[1000000+5];
int next[1000000+5];
void getnext() {
next[0]=-1;
int i=0, j=-1;
while(b[i]!='\0') {
if(j==-1||b[i]==b[j]) {
i++;
j++;
next[i]=j;
}
else j=next[j];
}
}
void kmp() {
getnext();
int i=0, j=0;
int n=strlen(a), m=strlen(b);
while(i<n&&j<m) {
if(a[i]==b[j]||j==-1) {
i++;
j++;
}
else j=next[j];
}
if(j>=m) printf("YES\n");
else printf("NO\n");
}
int main() {
while(~scanf("%s %s", a, b)) {
kmp();
}
return 0;
}