数据结构实验之图论六:村村通公路

数据结构实验之图论六:村村通公路

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
当前农村公路建设正如火如荼的展开,某乡镇政府决定实现村村通公路,工程师现有各个村落之间的原始道路统计数据表,表中列出了各村之间可以建设公路的若干条道路的成本,你的任务是根据给出的数据表,求使得每个村都有公路连通所需要的最低成本。
Input
连续多组数据输入,每组数据包括村落数目N(N <= 1000)和可供选择的道路数目M(M <= 3000),随后M行对应M条道路,每行给出3个正整数,分别是该条道路直接连通的两个村庄的编号和修建该道路的预算成本,村庄从1~N编号。 
Output
输出使每个村庄都有公路连通所需要的最低成本,如果输入数据不能使所有村庄畅通,则输出-1,表示有些村庄之间没有路连通。 
Example Input
5 8
1 2 12
1 3 9
1 4 11
1 5 3
2 3 6
2 4 9
3 4 4
4 5 6
Example Output
19
Hint
 
Author
xam  
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
struct node {
    int u, v;
    int w;
}edge[3000+5];
int pre[1000+5];
int root(int x) {
    int y=x;
    while(x!=pre[x]) {
        x=pre[x];
    }
    while(y!=x) {
        int z=pre[y];
        pre[y]=x;
        y=z;
    }
    return x;
}
bool cmp(node a, node b) {
    return a.w<b.w;
}
int main() {
    int n, m;
    while(~scanf("%d %d", &n, &m)) {
        for(int i=1;i<=n;i++)
            pre[i]=i;
        for(int i=0;i<m;i++)
            scanf("%d %d %d", &edge[i].u, &edge[i].v, &edge[i].w);
        int ans=0;
        sort(edge,edge+m,cmp);
        for(int i=0;i<m;i++) {
            if(root(edge[i].u)!=root(edge[i].v)) {
                pre[root(edge[i].u)]=edge[i].v;
                ans+=edge[i].w;
            }
        }
        int cnt=0;
        for(int i=1;i<=n;i++)
            if(pre[i]==i) cnt++;
        printf("%d\n", cnt==1?ans:-1);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值