数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Example Input
abc,,de,g,,f,,,
Example Output
3
Hint
 
Author

 xam 

#include <cstdio>
#include <algorithm>
using namespace std;
struct tree {
    char data;
    tree *l, *r;
};
char s[50+5];
int ans;
int cou;
tree *creat() {
    char c=s[ans++];
    tree *root;
    if(c==',') root=NULL;
    else {
        root=new tree;
        root->data=c;
        root->l=creat();
        root->r=creat();
    }
    return root;
}
void level_count(tree *root) {
    if(root) {
        if(root->l==NULL&&root->r==NULL) cou++;
        if(root->l) level_count(root->l);
        if(root->r) level_count(root->r);
    }
    return ;
}
int main() {
    while(~scanf("%s", s)) {
        cou=ans=0;
        tree *root=creat();
        level_count(root);
        printf("%d\n", cou);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值