poj 1247

Magnificent Meatballs

Time Limit: 1000MS

Memory Limit: 10000K

Description

Sam and Ella run a catering service. They like to put on a show when serving meatballs to guests seated at round tables. They march out of the kitchen with pots of meatballs and start serving adjacent guests. Ella goes counterclockwise and Sam goes clockwise, until they both plop down their last meatball, at the same time, again at adjacent guests. This impressive routine can on ly be accomplished if they can divide the table into two sections, each having the same number of meatballs. You are to write a program to assist them. At these catering events, each table seats 2 <= N <= 30 guests. Each guest orders at least on e and at most nine meatballs. Each place at the table is numbered from 1 to N, with the host at position 1 and the host's spouse at position N. Sam always serves the host first then proceeds to serve guests in increasing order. Ella serves the spouse first, then serves guests in decreasing order. The figures illustrate the first two example input cases.

Input

Input consists of on e or more test cases. Each test case contains the number of guests N followed by meatballs ordered by each guest, from guest 1 to guest N. The end of the input is a line with a single zero.

Output

For each table, output a single line with the ending positions for Sam and Ella, or the sentence indicating an equal partitioning isn't possible. Use the exact formatting shown below.

Sample Input

5 9 4 2 8 3
5 3 9 4 2 8
6 1 2 1 2 1 2
6 1 2 1 2 1 1
0

Sample Output

Sam stops at position 2 and Ella stops at position 3.
No equal partitioning.
No equal partitioning.
Sam stops at position 3 and Ella stops at position 4.

Source

Mid-Central USA 2002



import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
int num,sum=0,mid=0,p1=0;
int[] b;
do{
num=sc.nextInt();
if(num==0)
break;
p1=0;
sum=0;
mid=0;
b=new int[num];
for(int i=0;i<num;i++){
b[i]=sc.nextInt();
sum+=b[i];
}
mid=sum/2;
if((sum%2)!=0){
System.out.println("No equal partitioning.");
}else{
for(int i=0;i<num;i++){
p1+=b[i];
if(p1==mid){
System.out.println("Sam stops at position "+(i+1)+" and Ella stops at position "+(i+2)+".");
break;
}else if(p1>mid){
System.out.println("No equal partitioning.");
break;
}
}
}
}while(true);
}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值