Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 63934 Accepted Submission(s): 23978
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
//a^a mod 10
#include<stdio.h>
using namespace std;
long long power(long long a,long long n,long long mod)
{
long long res=1;
while(n>0)
{
if(n&1)
res=res*a%mod;
a=a*a%mod;
n>>=1;
}
return res;
}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
long long a;
scanf("%lld",&a);
long long res=power(a,a,10);
printf("%lld\n",res);
}
return 0;
}