HDU 1856 More is better ( 并查集)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 32320    Accepted Submission(s): 11390


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
 
 
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
 

Sample Output
 
 
4
2

这道题就是找并查集集合中最多的元素个数,间接朋友,直接朋友都算朋友,可以在同一个房间,问这些房间中最大人数,这里用了数组存放每个房间人数,但是刚开始加错方向了,一直错。注意刚开始每个房间都有一个人,当n为0时也是输出1,这个当时忘考虑了。

#include<stdio.h>
#include<string.h>
using namespace std;
int f[10000005];//选一个人当大哥,记录大哥的 
int vis[10000005];
int find(int x)//找老大 
{
	int r=x;
	while(f[r]!=r)
	{
		r=f[r];
	}
	int i=x,j;
	while(i!=r)
	{
		j=f[i];
		f[i]=r;
		i=j;
	}
	return r;
}
void fun()//初始化 
{
	for(int i=0;i<=10000005;i++)
	{
		f[i]=i;//刚开始自己和自己认识 
		vis[i]=1;//以i为大哥的房间就自己一个人 
	}
	return;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		fun();
		int sum=1;//刚开始至少一人 
		int a,b;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			int fx=find(a);
			int fy=find(b);
			if(fx!=fy)//二个人不是同一个大哥,但二人是朋友 
			{
				f[fx]=fy;//fy也当fx房间的大哥,都是朋友了 
				vis[fy]+=vis[fx];//可以一起到fy大哥的房间 
			}
			if(sum<vis[fy])//动态比较,一直记录最大值 
			{
				sum=vis[fy];
			}
		}
		printf("%d\n",sum);
	}
	return 0;	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值