HDU 4081 Qin Shi Huang's National Road System(枚举+最小生成树)

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9535    Accepted Submission(s): 3381


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input
 
 
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output
 
 
65.00 70.00

    这道题我想的是每一边都枚举,,二个for循环,每次让这两点边权值为0,调用prim算法,保存比率,在求出来所有比率中选最大的,毫无置疑的超时了。然后就不会了,唉。

    网上思路:

        先建一棵最小生成树,然后再从这n个城市中选择2个城市,把二者之间的路看做用法术造的路。如果这条路在最小生成树上,即去掉这条边后最小生成树会变成两棵独立的树,那么A/B就是(二者城市的人口数总和/最小生成树的值减去二者之间的长度);如果这条路不在生成树上,那么为了使A/B最大,我们要在最小生成树上删除一条权值最大的边使得生成树分为两棵树,同时这2个城市不在同一颗树上,然后就可以把这两个城市之间的路视为用法术造出的路,A/B就是(二者城市的人口数总和/最小生成树的值减去二者之间某条使二者连通的边的最大长度)。
综上:我们可以使用used[i][j]表示i与j之间的边是否在最小生成树上,dp[i][j]表示i到j之间的使得i与j连通的权值最大的边的权值。在prim内更新dp数组。

#include<stdio.h>
#include<iostream>
#include<string>  
#include<math.h>
#include<queue>
#include<string.h> 
#include<algorithm>  
using namespace std; 
#define inf 0x3f3f3f3f 
double mat[1005][1005];//原始关系图 
bool use[1005][1005];//路径是否在最小生成树中 
double dp[1005][1005];//dp[i][j]:i到j路径中最大的边权值。 
int pri[1005];//记录节点前继 
struct node{
	double x,y;//城市坐标 
	int num;//人数 
}p[1005];
double len(node a,node b)//权值计算 
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}  
double dist[1005];  
int vis[1005];
int n;
double prim(int v)//prim模板   
{  
    double sum=0;  
    memset(vis,0,sizeof(vis));  
    for(int i=0;i<n;i++)  
    {  
        dist[i]=mat[v][i];
		pri[i]=v;  
    }
    dist[v]=0;  
    vis[v]=1;  
    for(int i=1;i<n;i++)  
    {   int pos;  
        double minn=inf;  
        for(int j=0;j<n;j++)  
        {  
            if(!vis[j]&&dist[j]<minn)  
            {  
                pos=j;
                minn=dist[j];  
            }  
        }  
        vis[pos]=1;  
        sum+=minn;
		use[pos][pri[pos]]=use[pri[pos]][pos]=true;//在最小生成树中  
        for(int j=0;j<n;j++)  
        {  
            if(!vis[j]&&dist[j]>mat[pos][j])
            {
            	dist[j]=mat[pos][j];
				pri[j]=pos; 
			}
			if(vis[j]&&j!=pos)//更新 
			{
				dp[pos][j]=dp[j][pos]=max(dp[j][pri[pos]],dist[pos]);
			}
        }  
    }    
    return sum;  
}
void dfs()
{
	double ans=-1;
	double sum=prim(0);
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			if(i==j) continue;
			if(use[i][j])//在 
			{
				ans=max(ans,(p[i].num+p[j].num+0.0)/(sum-mat[i][j]));
			}
			else//不在 
			{
				ans=max(ans,(p[i].num+p[j].num+0.0)/(sum-dp[i][j]));
			}
		}
	}
	printf("%.2lf\n",ans);
	return;
} 
int main()  
{  
    int m,t;
	scanf("%d",&t);
	  
    while(t--)
    {  	
    	scanf("%d",&n);
    	memset(use,false,sizeof(use));
    	memset(dp,0,sizeof(dp));
    	memset(mat,inf,sizeof(mat));
        for(int i=0;i<n;i++)//各端点连接的权值   
        { 
            cin>>p[i].x>>p[i].y>>p[i].num;
        }
        for(int i=0;i<n;i++)
        {
        	for(int j=0;j<n;j++)
        	{
        		mat[i][j]=len(p[i],p[j]);
			}
		}
		dfs();
    } 
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值