HDU 2579 Dating with girls(2)(bfs+三维标记)

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4105    Accepted Submission(s): 1216


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
 
 
1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.
 

Sample Output
 
 
7

本来敲好,测试,一气呵成,终于有能一遍过的了,结果wa(简直大写的!?),没找到错,一搜博客才知道,没有想能不能重复走,以前我都是第一个考虑这个因素的,唉,脑袋本来就不灵光,再加上今天中午没睡觉。

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
int f[4][2]={0,1,1,0,0,-1,-1,0};
struct node{
	int x,y;
	int temp;
};
char mat[105][105];
int vis[105][105][11];
int n,m,k,x1,y1,x2,y2;
void bfs()
{
	node s,t;
	queue<node>q;
	s.x=x1;
	s.y=y1;
	s.temp =0;
	vis[x1][y1][0]=1;
	q.push(s);
	while(!q.empty())
	{
		t=q.front();
		q.pop();
		if(t.x == x2&&t.y == y2)
		{
			printf("%d\n",t.temp);
			return;
		}
		for(int i=0;i<4;i++)
		{
			s.x=t.x+f[i][0];
			s.y=t.y+f[i][1];
			s.temp=t.temp+1;
			int flag=0;
			if(s.temp%k==0&&mat[s.x][s.y]=='#')
			{//石头可以消失 
				mat[s.x][s.y]='.';
				flag=1;
			}
			if(s.x<0||s.x>=n||s.y<0||s.y>=m||vis[s.x][s.y][s.temp%k]||mat[s.x][s.y]=='#')
			continue; 
			if(flag) mat[s.x][s.y]='#';
			vis[s.x][s.y][s.temp%k]=1;//标记状态 
			q.push(s);
		}	
	}
	printf("Please give me another chance!\n");
	return;	
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(vis,0,sizeof(vis));
		scanf("%d%d%d",&n,&m,&k);
		for(int i=0;i<n;i++)
			scanf("%s",mat[i]);
		for(int i=0;i<n;i++)
			for(int j=0;j<m;j++)
			{
				if(mat[i][j]=='Y')
				{
					x1=i;y1=j;//起点 
				}
				if(mat[i][j]=='G')
				{
					x2=i;y2=j;//终点 
				}
			}
		bfs();
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值