Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 281619 Accepted Submission(s): 66887
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
题意:输出最大子段和以及元素的起始、终止位置
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[100002];
int n;
void maxsum()
{
int s=0;//起点
int e=0;//终点
int sum=0;
int maxn=-99999;
int k=0;
for(int i=0;i<n;i++)
{
sum+=a[i];
if(maxn<sum)
{
maxn=sum;
s=k;
e=i;
}
if(sum<0)
{
sum=0;
k=i+1;
}
}
//这里s+1,e+1,是因为此题下标以一开始
printf("%d %d %d\n",maxn,s+1,e+1);
}
int main()
{
int t;
scanf("%d",&t);
int ca=1;
while(t--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
printf("Case %d:\n",ca++);
maxsum();
if(t) printf("\n");
}
}