HDU 1078 FatMouse and Cheese(记忆化dfs)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14142    Accepted Submission(s): 5978

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.
FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 
a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1

1 2 5

10 11 6

12 12 7

-1 -1

Sample Output

37

题意:给n,k两个整数,在n*n矩阵中,可以垂直或水平移动到达一个格点,最远移动距离为k,当前到达格点的权值一定要大于上一个起点的权值,一直到无法移动(在可移动范围内,权值没用比当前格点大的),输出权值之和。

思路:记忆化搜索

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mat[105][105];//原权值 
int dp[105][105];//保存以i,j为起点,k步内的最大值
int f[4][2]={0,1,1,0,-1,0,0,-1};
int n,k;
int dfs(int x,int y) {
	int maxn=0;
	if(dp[x][y]>=0) return dp[x][y];//已经找到以x,y为起点的最大值,直接返回 
	for(int i=1;i<=k;i++) {
		for(int j=0;j<4;j++) {
			int xx=x+i*f[j][0];
			int yy=y+i*f[j][1];
			if(xx>=0&&yy>=0&&yy<n&&xx<n&&mat[x][y]<mat[xx][yy]) {
				maxn=max(maxn,dfs(xx,yy));
			}
		}	
	}
	return dp[x][y]=maxn+mat[x][y];//以x,y为起点,k步内的最大值。 
}
int main()
{
	while(~scanf("%d%d",&n,&k)&&n!=-1&&k!=-1) {
		for(int i=0;i<n;i++) {
			for(int j=0;j<n;j++) {
				scanf("%d",&mat[i][j]);
			}
		}
		memset(dp,-1,sizeof(dp));
		printf("%d\n",dfs(0,0));
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值