数据结构实验之求二叉树后序遍历和层次遍历

数据结构实验之求二叉树后序遍历和层次遍历
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description

已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。
Input

输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。
Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。
Sample Input

2
abdegcf
dbgeafc
xnliu
lnixu
Sample Output

dgebfca
abcdefg
linux
xnuli
Hint

Source

ma6174

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
struct tree
{
    char data;
    struct tree*left,*right;
}*link[54];
char str1[54],str2[54];
struct tree*getbuild(int len,char *str1,char *str2)
{
    if(len==0)return NULL;//后序遍历和还原二叉树,在还原的过程中就后序遍历了
    struct tree*root;
    root=(struct tree*)malloc(sizeof(struct tree));
    root->data=str1[0];
    int i;
    for(i=0;i<len;i++)
    {
        if(str2[i]==root->data)
            break;//找结点,知道后就退出
    }
    root->left=getbuild(i,str1+1,str2);//左子树的长度,左子树在str1中的位置,左子树在str2中的位置
    root->right=getbuild(len-i-1,str1+i+1,str2+i+1);
    printf("%c",root->data);
    return root;
}
void ceng(struct tree*root)//层序遍历,入队,先让自己的左右孩子入队后自己再出队
{
    if(root)
    {
        int i=0,j=0;
        link[j++]=root;
        while(i<j)//当没有可以入队的元素的时候,就出队
        {
            if(link[i])
            {
                link[j++]=link[i]->left;
                link[j++]=link[i]->right;
                printf("%c",link[i]->data);
            }
            i++;
        }
    }
}
int main()
{
    int t,len;
    scanf("%d",&t);
    while(t--)
    {
        struct tree*root;
        scanf("%s%s",str1,str2);
        len=strlen(str2);
        root=getbuild(len,str1,str2);
        printf("\n");
        ceng(root);
        printf("\n");
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值