PAT甲级1001 A+B Format (20 分)

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991

题目分析:将整型化为字符串再做处理。

C:

#include<stdio.h>
#include<math.h>
#include<string.h>

int main(){
    int a,b,i=0,flag=0,temp=0;
    char str[15];
    scanf("%d %d",&a,&b);
    if(a+b < 0){
        flag = -1;
    }
    sprintf(str,"%d",abs(a+b));
    if(flag == -1){
        printf("-");
    }
    while(str[i] != '\0'){
        if((strlen(str)-i)%3 == 0 && strlen(str)-1 != i && temp != 0){
            printf(",");
        }
        if(temp == 0){
            temp = 1;
        }
        printf("%c",str[i]);
        ++i;
    }
    return 0;
}

注意的问题:

sprintf的用法:int sprintf(char *str, const char *format, …)发送格式化输出到str所指向的字符串。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值