动态规划 002:Charm Bracelet

Charm Bracelet

总时间限制: 1000ms 内存限制: 65536kB
描述
Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a ‘desirability’ factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
输出
Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23

0-1背包问题——在限定体积的背包里装尽可能价值高的物品
分解问题:
1.数量为i,体积为j,价值最大为dp[i][j];
2.目标结果——dp[N][M];
初始化: i=1时,若i.volumn<j,则dp[i][j]=i.value
递推公式 :dp[i][j]=max(dp[i-1][j],dp[i-1][j-体积]+这个的价值)
即用第i个物品和不用第i个物品更大的那个值,
因为第i的值仅和第i-1行有关,即可用滚动数组,节省空间

#include<iostream>
#include<algorithm>
using namespace std;

int W[3500];
int D[3500];
int dp[13000]={0};        
//取前i种物品,其总体积不超过j 
						//dp[N][M]为所需答案 
int main(){
	int N,M;
	cin>>N>>M;               
	for (int i=1;i<=N;i++){
		cin>>W[i]>>D[i];         //每个物品的体积和价值 
	}
	for (int i=1;i<=N;i++){
		for (int j=M;j>=1;j--){
		if(j-W[i]>=0)
		dp[j]=max(dp[j],dp[j-W[i]]+D[i]);
		}
	}
	cout<<dp[M];
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值